Follow

Step 4: System Requirements Check*

Due to rapidly changing browsers system checks are limited in their ability to keep up. The following system checks may help pinpoint issues, but passing a system checkup via one of these links does not necessarily indicate that you are all set. Please refer to the system requirements documentation below for exact specifications.

Please click the appropriate check(s) below to verify* your setup:

Complete system requirements are listed below. Updated 9/09/2015. Please note we anticipate that as browsers continue to update these requirements may need to be updated throughout the school year each year. Please see special chromebook notes below the document.

 

NOTE for CHROMEBOOKS: In general, we find that Chromebooks work in our environment.  However, none of our site providers specifically support Chromebooks, so we cannot make the claim "fully supported."  We recommend that Chromebook and all mobile device users have access to a fully supported device to use as a backup. That said, we know of only 2 issues with Chromebook usage:

1) A few of our courses may ask a student to install software, examples include the current version of Earth Science (which is being revised for fall) and some of the computer language programming IT courses.  These are generally not compatible with Chromebooks.

2) Our world language classes require students to communicate with their instructors.  Chromebooks tend to be incompatible with web-conferencing outside of google hangouts. You may also want to use an audio recording app such as the one found in this article at http://www.apowersoft.com/record-audio-on-chromebook.html 

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk